Internet connection drops when under heavy load.

SatsumomoSatsumomo Rated PG!Registered User regular
Hey everyone,

So I'm having a very annoying issue with my internet connection. First things first:

Internet: 20Mb up/down fiber

Router: TP-Link AC1200 or Linksys 54GL (Issue happens with either of them)

Connection: Wireless 2.4GHz

So this is a problem I've reported to my ISP several times and they've been completely unable to fix it, so I'm here wondering if maybe I'm doing something wrong on my end. These guys provide me with a POS modem that has a Wi-Fi range of about 3m and is blocked to the wazoo (Can't even open ports) so I got my own router and had them activate a "bridge" mode.

So I first started with the 54GL and it works very well, until I decide to do something connection heavy, such as download a torrent or a Steam game. When that happens, the connection starts to slow down until it hits 5kb/s and then it dies. What's most interesting with this, is that it makes the router completely inaccessible, so typing the gateway IP does nothing.

The only way to fix this issue is to turn off the router, restart it, go into settings, set MAC to default, save, then clone the modem's MAC address again, save and then I have internet again.

This also happens with the AC1200 router. Interestingly enough, something that really wasn't a huge connection hog would cause the same symptom:

If I create a Terraria server on my PC (W10) and have people connect, it works. BUT, if I create the same server on a small media PC I own, and someone remote connects to it, my connection drops. The mini PC had Windows 10, I then tried with Windows 7 and it was the same result.

What I'm trying to find out here, is it my ISP? Do I have two duds of routers? Do I need to change some setting? What's going on?

Thank you so much for reading, let me know if you need more info.

Posts

  • BlazeFireBlazeFire Registered User regular
    No promise that this is the same issue but I'll tell you my story.

    I was having similar symptoms where over time, or if I did something like download a torrent, the router would bog down then eventually drop connection. It turned out there were too many connections being made and the old WRT54G I had couldn't handle it all. I got a router with better specs (i.e. more ram) and I haven't had the issue yet. I wouldn't expect the AC1200 to have this kind of issue though.

    Can you plug a computer directly into the modem (bypassing the router) and run some tests? It is always good to try to narrow down what is causing the issue.

    ArbitraryDescriptorbowen
  • ArbitraryDescriptorArbitraryDescriptor Registered User regular
    Not clear if you isolated the Wifi antenna as the problem?

    My last wifi router, as it slouched toward its grave, would drop under load, but the wired connections were unaffected.

  • MugsleyMugsley Registered User regular
    I'm not quite sure what you mean by "bridge mode." For my FiOS router, I simply disabled the wifi and connected my TPLink router via ethernet cable (not the WAN port on the ISP's router, but I think you know this).


    Unlikely the problem, but do you have QoS enabled?

  • SatsumomoSatsumomo Rated PG! Registered User regular
    Yeah, today's test will be to remove the bridge mode (But I need to call my ISP for that) in order to bypass the router. I will need to move my PC to the living room where the router is to check with the cable, but I don't think it's the WiFi, it fails on the 5Ghz band as well when using my phone.

  • CambiataCambiata Commander Shepard The likes of which even GAWD has never seenRegistered User regular
    edited September 2017
    Generally speaking if there's a way for you to use your own router (ie, completely eliminate the provider's router), that fixes most problems like this. Dunno if that's possible for you though, depends on the provider.

    Edit: Don't necessarily believe the frontline support if they tell you it's impossible to run your own router. For example I found out just before I stopped working for Fios that there are MoCa bridges that will allow you to somehow still maintain the correct information for the TV service while also using your own router. But I've never installed one so I don't have a clue how they work. Your best bet on both finding out if this is possible and in seeing if other people have had your issue is to poke around the internet for clues, like at http://www.dslreports.com/ I frequently found better information about the product that I was technical support for in sources like that than I found from the company intranet.

    Cambiata on
    Fry
  • BlazeFireBlazeFire Registered User regular
    edited September 2017
    nm, I misread.

    BlazeFire on
  • TofystedethTofystedeth veni, veneri, vamoosi Registered User regular
    The 54GL is a great piece of hardware. For 2007.
    I mean, I still use mine, but it's definitely getting long in tooth, and I'm not exactly doing anything that makes a bunch of simultaneous connections.
    That said, with it happening to both and your description of the fix, i definitely suspect the issue is with the ISPs modem being at dealing with the bridge mode. Not sure how your ISP has things set up, but the default state for your router should be non-bridged. It normally doesn't require their intervention to just use your router as a router.

    steam_sig.png
    bowen
  • ShadowfireShadowfire Vermont, in the middle of nowhereRegistered User regular
    Mugsley wrote: »
    I'm not quite sure what you mean by "bridge mode." For my FiOS router, I simply disabled the wifi and connected my TPLink router via ethernet cable (not the WAN port on the ISP's router, but I think you know this).

    Unlikely the problem, but do you have QoS enabled?

    Bridge Mode is a setting on a lot of ISP provided gateways and routers that turn off the DHCP server and all wireless settings. It turns the device into a dumb box that just translates info for your router to read. If you're just disabling the wifi, you're running a double NAT which isn't a healthy connection. That's where a lot of people run into things like their PS4 saying "Strict NAT."

    For the OP: 20Mb fiber? That seems slow for fiber. :\

    So, let's talk about that router being in bridge mode. Are you sure it's in bridge mode? I'm sure the wireless is off, but you might verify with your ISP that it's actually in bridge mode.

    And who is this fiber provider? The fiber providers up here (Vtel, ECFiber, and Topsham Communications) all put a big box on the outside of your home (inside if you're picky), and just run an ethernet cord into the home for you to use any router with.

    WiiU: Windrunner ; Guild Wars 2: Shadowfire.3940 ; PSN: Bradcopter
  • SatsumomoSatsumomo Rated PG! Registered User regular
    I'm in Mexico, I'm paying the basic package for 20mb, they offer up to 300mb I believe?

    But good news is that connecting my PC directly to my router I was able to leave it overnight and downloaded something like 40GB total of data, no problems. I will make a 2nd test of connecting it through WiFi and trying again.

    I didn't mention it but this whole issue started recently, I was able to use the WiFi connection with no problems.

  • MugsleyMugsley Registered User regular
    @Cambiata @Shadowfire I hope you're both happy because I'm venturing down the rabbit hole that is MoCA on FIOS, at dslreports.

    CambiataShadowfire
  • SatsumomoSatsumomo Rated PG! Registered User regular
    Well after several tests, it seems it was my dongle that caused all these issues?

    Still doesn't explain why the media PC would make the connections drop... I'll take it though. Thanks!

Sign In or Register to comment.