As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Popping sounds from PC sound & video lag issues

SteevLSteevL What can I do for you?Registered User regular
I built this PC a little over a year ago, but it's only over the last 3-4 months that I really started noticing this issue. I'll be listening to music via iTunes, and suddenly I get a lot of crackling/popping sounds. It doesn't completely overpower the music, but it can get quite distracting, especially during quieter songs. This also happens if I'm listening to music via youtube. The common thing here seems to be that I have a web browser open when the crackling starts happening, and it seems like looking at a site like Twitter or Facebook increases the likelihood of it happening, but I can't make it happen consistently. Initially I thought it was the new Logitech speakers I bought in August, but then I plugged in some earbuds directly into my PC and had the same thing happen.

Similarly, and possibly related, I've noticed while watching videos in my browser that the video will start to lag behind the sound if I switch tabs. The longer it's not the active window, the greater the lag becomes. I've seen this happen in both Google Chrome and Firefox. I've even watched it happen to a video in Firefox while I used Chrome.

Here are my PC specs:
Motherboard: ASUS Z170-A
Processor: Intel Core i5-6600K
Video card: GeForce GTX 1060
Memory: 16GB (2 x 8GB)
OS: Windows 10

Has anyone else experienced this and, do you know of a possible fix?

I've definitely found reports about the video lag while searching the internet, but none of the solutions worked for me.

Posts

  • SoggybiscuitSoggybiscuit 4.5 MV of POWER! Registered User regular
    Popping could be several things, but I would check all of your cables (including USB/Power/Display) and make sure you don't have something accidentally shorting on the case. Make sure your WiFi antennas (if you have them) are also located far from the audio cables. Make sure you haven't damaged your audio port(s). If you are using the port on the case, make sure the cable plugged into the motherboard is not loose. Another thing, that most don't think of: If you have AT&T/T-mobile/GSM Carrier for your mobile service, don't set your phone anywhere near your audio cables, as it will almost certainly cause cracking and popping.

    As for the sound lagging behind, you could have memory issues. Have you checked to see if your CPU heatsink is seated properly? Do you use any extensions? If so, try disabling them to help isolate the problem. Have you tried updating your drivers? If worse comes to worse, you could do a purge and reinstall the OS.

    Steam - Synthetic Violence | XBOX Live - Cannonfuse | PSN - CastleBravo | Twitch - SoggybiscuitPA
    SteevL
  • SatsumomoSatsumomo Rated PG! Registered User regular
    I get this too with an HP laptop, whenever there is high CPU load, the sound will have a bunch of crackling and popping. I would first try to see if there's an updated driver for the sound drivers, I had that motherboard as well on my desktop PC and never had any audio issues during the year I owned it.

  • SteevLSteevL What can I do for you? Registered User regular
    I forgot to respond to this yesterday. Thanks for the advice so far. I actually did update the sound drivers a few weeks ago, because I had forgotten to do so earlier in the year after I had to reinstall Windows. It seemed to fix the problem at the time, but at best I think the problem just became less frequent.

    I probably should open the case and have a look. In August we moved across the country about 2000 miles, and both our PCs went along for the ride in our car. Who knows what might have happened inside? I actually did have a third PC (which traveled via a moving container) have its CPU heatsink get dislodged during the move, which I figured out after it kept randomly shutting down without warning. On this PC, though, I don't think I've ever had the audio get all crackly/poppy while playing a game; it only seems to be while I am browsing websites and listening to music.

    The audio crackling happens both through the speakers, connected through the motherboard's interface in the back, and through earbuds connected into the case's front audio port.

    I have Verizon for my phone service, so I'm assuming it won't affect my sound? I'll move my phone away if the crackling happens again, but I haven't had that particular issue with my phone affecting audio for a long time.

    I do have a few Chrome extensions installed. Maybe I'll try running only Firefox (which is just my backup browser) and see if that has any effect when switching tabs while watching video.

  • Marty81Marty81 Registered User regular
    This is kind of a long shot, but with higher-end audio equipment crackling usually appears when the *sample buffer size* is too small. I don't know if you have the ability to see or change your onboard audio card's sample buffer size, but if you do it would probably be in the driver software somewhere. I have a usb audio interface, and here's what the page looks like where I can change the sample buffer size.

    ls7h71m7tswi.jpg

    (You probably don't have access to ASIO. You're probably using DirectSound or WASAPI or something like that.)

    In case you're curious, the smaller the sample buffer size, the lower the audio latency but the higher the CPU usage and the higher the chance for crackling and other unwanted audio artifacts.

  • SteevLSteevL What can I do for you? Registered User regular
    Yeah, unfortunately I don't have access to anything like that control panel above. Thanks for the suggestion, though!

    But I did do some experimenting just now, and I'm 80% sure that I've identified the cause: a Chrome extension called Disable HTML5 Autoplay. It's always been a bit of a clumsy extension, but I found it useful to stop ads and stuff like that from autoplaying on websites.

    ...it also seems to have solved the crackling/popping issue.

    A shame. I liked being able to stop videos from playing automatically. But I like not having laggy videos and crackling sound a lot better! Time will tell if this is a permanent fix.

  • ShadowfireShadowfire Vermont, in the middle of nowhereRegistered User regular
    The beta branch of Chrome will mute autoplaying videos right now, not sure when that is hitting release though.

    WiiU: Windrunner ; Guild Wars 2: Shadowfire.3940 ; PSN: Bradcopter
    SteevL
  • SteevLSteevL What can I do for you? Registered User regular
    SteevL wrote: »
    Yeah, unfortunately I don't have access to anything like that control panel above. Thanks for the suggestion, though!

    But I did do some experimenting just now, and I'm 80% sure that I've identified the cause: a Chrome extension called Disable HTML5 Autoplay. It's always been a bit of a clumsy extension, but I found it useful to stop ads and stuff like that from autoplaying on websites.

    ...it also seems to have solved the crackling/popping issue.

    A shame. I liked being able to stop videos from playing automatically. But I like not having laggy videos and crackling sound a lot better! Time will tell if this is a permanent fix.

    Update: it wasn't a permanent fix! I really need to test this with a different browser while Chrome is closed and see if it still happens.

  • SteevLSteevL What can I do for you? Registered User regular
    edited August 2020
    Necropost time!

    So I was basically living with this issue for the last few years. I had kind of given up because every possible fix was the kind of thing where it seemed like it worked, and then a day or two later the sound started lagging behind in videos again and I'd also get the audio glitching.

    Until last week. I do believe I have finally fixed it! I stumbled across some youtube video with a suggestion for a fix. I almost didn't bother. There are a lot of youtube videos out there that try to fix this issue, and I was pretty skeptical. But holy shit, it seems to have worked. I've had glitchless audio since then, and when I tab away from a video, it's still perfectly in sync when I come back to it after several minutes.

    Here's what fixed it: changing audio drivers. Historically, Windows has picked the best drivers for my stuff, but apparently using Realtek High Definition Audio drivers is bad with my onboard sound. I switched to the generic "High Definition Audio Device" driver last week and the issues have not reared their ugly heads:

    d3z0ob10tnxp.png

    Anyway, thanks to everyone who had suggestions a few years ago when I created this thread. I figured it'd nice to post an update since this was a very frustrating issue for me to live with, and I've stumbled across so many "anyone know how to fix this?" help threads on the internet that ended with no resolution. Maybe this will help someone else.

    SteevL on
    ShadowfireElvenshaeJaysonFour
Sign In or Register to comment.