As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread:

Displayport/HP desktop issues

First off: Displayport fucking sucks and I hate it, and the fact that all the new HP business PCs come with only displayport on the back is the dumbest shit.

Now, on to my problem.

I have a monitor (Lenovo ThinkVision P27u-10) connected via DP to a KVM (Monoprice 2 port USB Displayport cable KVM switch with remote port selector)

This setup work beautifully with the HP EliteDesk 800 G1 and G2 desktops. No issues at all.

It doesn't work at all with the newest models, the 800 G4s, and I cannot fucking figure out what is going on. It won't display anything from a machine actively running Win10, or a machine I'm trying to network boot.

I've tried every cable combination in the book and I don't get shit from the G4s. Different brands of DP cable, DP to HDMI adapters, I've tried bypassing the video from the KVM and plugging the PCs directly into the monitor and I still get nothing. The monitor just goes into Power Save mode.

They're using onboard video, no cards. And I know they work because when I had them hooked up DP to DVI to an oldass crappy Philips screen they displayed fine.

But I can't do that because there is no DVI on this new monitor.

I'm about ready to throw all this equipment down several flights of stairs. Please help.

Do... Re.... Mi... Ti... La...
Do... Re... Mi... So... Fa.... Do... Re.... Do...
Forget it...


  • Bendery It Like BeckhamBendery It Like Beckham Hopeless Registered User regular
    edited September 2019
    So I understand. Old Setup - Lenovo Monitor - DP -> KVM -> DP -> G1 and G2

    New Setup Lenovo Monitor - DP -> KVM -> DP -> G4
    If that's correct, have you updated the UEFI firmware?

    Additionally, I'd check for an embedded Video switch in the UEFI menu, HP sometimes has an embedded video switch with 3 settings - Disabled - Auto - Always Enabled
    The only thing the Auto setting does automatically on my servers is suck my ass, change that to disabled or always enabled. <- Down side to this is it may constantly force a monitor to appear in the OS and wont care if one is actually hooked up or not. You can disable that monitor in display settings.

    Bendery It Like Beckham on
Sign In or Register to comment.