As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Shortcut/toll to easy switch audio output?

So on my PC I find my self alternating between sending audio to three different outputs, doing so can be done by clicking the speaker tray icon next to clock, clicking again to activate a drop down menu and then finally a third click to pick the desired output. However as I do this sometimes several times a day I would like a better solution - is there one?

Ideal would be like if I could have say:
CTRL-F1 = Speakers, using a mini-jack connector on the motherboard.
CTRL-F2 = Headphones, using an external USB connected headphone DAC+amp.
CTRL-F3 = Optical, goes to an audiophile DAC and on to a big stereo.

If I also could have different sources go to different outputs that would be even better ie. WIndows notificationsounds to the speakers, streaming music from a web browser sometimes to the headphones and sometimes to the optical output.

Bones heal, glory is forever.

Posts

  • Zilla360Zilla360 21st Century. |She/Her| Trans* Woman In Aviators Firing A Bazooka. ⚛️Registered User regular
    Hmmm. A tricky one. I assume you're on Windows 10? The only thing I can think of that *might* work is some combo of PowerShell and/or AutoHotKey:

    https://www.autohotkey.com/docs/commands/SoundSet.htm

    I've not used PowerShell enough to know if you can control sound settings with it, but maybe? IDK.

    NH844lc.png | PSN | GACSALB.jpg My Blog |🏳️‍⚧️♥️
    BlindZenDriver
  • Zilla360Zilla360 21st Century. |She/Her| Trans* Woman In Aviators Firing A Bazooka. ⚛️Registered User regular
    Or maybe what would be perhaps easier is a hardware solution of some kind, like this, with an IR remote:
    https://smile.amazon.co.uk/LiNKFOR-Switcher-Supports-Dolby-AC3-Compatible/dp/B07MFJKMRB

    NH844lc.png | PSN | GACSALB.jpg My Blog |🏳️‍⚧️♥️
    Shadowfire
  • XantusXantus Registered User regular
    Paths of Exiled - (waffenheimer)
    Domination -> BrunswickBeardcombe - SuperKudukuJazz
    Zilla360BlindZenDriver
  • BlindZenDriverBlindZenDriver Registered User regular
    Xantus wrote: »

    Spot on - how could I not find that when I looked. Thank you.
    I can report that SoundSwitch works well, it even handles that my USB Headphone DAC is not always connected to the PC ie. when not connected it does not try to switch to it and when connected I do not have to reconfigure SoundSwitch for it to be included.

    Also Thanks to @Zilla360 for suggestions. I actually have one like the switchbox you linked to, however since it is an optical only thing it would not do the trick in the PC scenario I mentioned. I can however report that those Optical switchboxes are pretty neat and surprisingly cheap also, the one I use was like $30 or so and still it comes with a remote and is well build with a metal case.

    Bones heal, glory is forever.
    Zilla360
  • EchoEcho ski-bap ba-dapModerator mod
    +1 on SoundSwitch, used it for years.

  • AthenorAthenor Battle Hardened Optimist The Skies of HiigaraRegistered User regular
    I need to do this in the worst way. For whatever reason, Firefox decides to play videos SUPER soft, and only returns to what I would consider to be normal volume if I switch the sound mode. Usually the quickest way to do this is to kick over the Spatial Sound to something else and switch it back, which requires a mouse. having it on a shortcut key would be much easier and faster.

    He/Him
  • BlindZenDriverBlindZenDriver Registered User regular
    Athenor wrote: »
    I need to do this in the worst way. For whatever reason, Firefox decides to play videos SUPER soft, and only returns to what I would consider to be normal volume if I switch the sound mode. Usually the quickest way to do this is to kick over the Spatial Sound to something else and switch it back, which requires a mouse. having it on a shortcut key would be much easier and faster.

    Not really an audio switching thing, but more a mixer setting.

    I assume you're using Windows 10 so try this.
    1. Right click the Speaker icon the tray area down right, it should be somewhere next to the clock.
    2. Select Volume mixer. There you'll find individual volume setting for each program, it only shows the programs that are running so make sure Firefox is running.
    3. Finally, increase the volume setting for Firefox and your problem should have been sorted.

    If Firefox was not set low in Volume mixer then it is likely something set with the plug ins that plays the videos in Firefox or on the site with the videos them self. Like for example youtube have a volume setting that stays the same moving from video to video, so if you set theirs low it stays low until you change it.

    Bones heal, glory is forever.
  • AthenorAthenor Battle Hardened Optimist The Skies of HiigaraRegistered User regular
    Athenor wrote: »
    I need to do this in the worst way. For whatever reason, Firefox decides to play videos SUPER soft, and only returns to what I would consider to be normal volume if I switch the sound mode. Usually the quickest way to do this is to kick over the Spatial Sound to something else and switch it back, which requires a mouse. having it on a shortcut key would be much easier and faster.

    Not really an audio switching thing, but more a mixer setting.

    I assume you're using Windows 10 so try this.
    1. Right click the Speaker icon the tray area down right, it should be somewhere next to the clock.
    2. Select Volume mixer. There you'll find individual volume setting for each program, it only shows the programs that are running so make sure Firefox is running.
    3. Finally, increase the volume setting for Firefox and your problem should have been sorted.

    If Firefox was not set low in Volume mixer then it is likely something set with the plug ins that plays the videos in Firefox or on the site with the videos them self. Like for example youtube have a volume setting that stays the same moving from video to video, so if you set theirs low it stays low until you change it.

    It's none of the mixer settings.

    Like I can hear the audio volume cut in half when I press J to go back 10 seconds in a video, or when switching videos. I've found articles saying it might be related to how Firefox processes videos with copyright claim data on them, which seems weird as it happens to me in Twitch as well. So it might be something with my popup blocker. But either way, trust me when I say I've got the sliders shoved as far to max volume as I can make them. :)

    He/Him
  • BlindZenDriverBlindZenDriver Registered User regular
    Athenor wrote: »
    It's none of the mixer settings.

    Like I can hear the audio volume cut in half when I press J to go back 10 seconds in a video, or when switching videos. I've found articles saying it might be related to how Firefox processes videos with copyright claim data on them, which seems weird as it happens to me in Twitch as well. So it might be something with my popup blocker. But either way, trust me when I say I've got the sliders shoved as far to max volume as I can make them. :)

    Annoying for sure.

    Likely you have tried already, but if not then try and see if the problems is also there running Firefox in Private mode (CTRL-SHIFT-P). That will make sure it is nothing something remembered by cookies.

    Bones heal, glory is forever.
Sign In or Register to comment.