As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Phone doesn't work right with new wifi

SmrtnikSmrtnik job boli zubRegistered User regular
Hello,
I recently got a new router because my old one died. We have a lot of networked devices (personal phones, work phone, laptop, kindle, kid's school tablet, thermostat, 2 chromecasts, etc...). Right around the same time, the personal phones (2 Pixel 4a) had a system update. And i noticed the internet went to crap on the phones, but only on wifi, was just fine on mobile.

At first i blamed it on the system update because literally every other device i tried in the house was fine. But then i tried the laptop, and it was having the same issue. Googling suggested the network card in laptop was very old so i bought a USB network card/antenna and it was fine after that. Then, my mom was visiting one day and brought her much newer laptop, but she had the same issue, and plugging in that USB antenna solved it. And then i took my phone to a friend's house and the wifi was fine. And also my phone was fine on my mom's apartment wifi.

So that has now firmly convinced me it's the new router. It's a pretty fancy one, supports two 5Ghz and two 2Ghz wifi channels, lots of configuration options. My guess is that there is some option turned on that doesn't work with Pixel 4a wifi. Any ideas what it could be?

What i mean by crappy wifi internet: pages take a minute to load that on other wifi pr mobile take seconds. YouTube preview images likewise. But if i go to speedtest website, it tells me i have 200MB down and 20 up.

steam_sig.png

Posts

  • MulletudeMulletude Registered User regular
    edited July 12
    It's possible the wifi channels you're using are being used by quite a few neighbors too. And maybe the new router is using different channels than the old?

    Edit- could probably post this in the networking thread in Moe's, a sub forum of g&t and get more eyes on it as well.

    Mulletude on
    XBL-Dug Danger WiiU-DugDanger Steam-http://steamcommunity.com/id/DugDanger/
    Shadowfire
  • SmrtnikSmrtnik job boli zub Registered User regular
    Mulletude wrote: »
    It's possible the wifi channels you're using are being used by quite a few neighbors too. And maybe the new router is using different channels than the old?

    Edit- could probably post this in the networking thread in Moe's, a sub forum of g&t and get more eyes on it as well.

    I have that setting on "automatic", figuring the router is figuring out the least used one, but maybe not.
    But also, many of the devices seem unaffected, which i wouldn't expect if that was the issue.

    steam_sig.png
  • MulletudeMulletude Registered User regular
    Oh, ok, I thought it was more than the phones. There are smarter people around here I'll defer to then :)

    XBL-Dug Danger WiiU-DugDanger Steam-http://steamcommunity.com/id/DugDanger/
  • deathnote666deathnote666 Registered User regular
    What encryption are you using for your wireless? Switch to WPA2-Personal and see if that has any effect.

    Not all encryption works with all devices.

  • a nu starta nu start Registered User regular
    I remember my Pixel 3 had problems with 5Ghz wifi on some devices. Stuff like dashcams and Gopros wouldn't connect. But my router worked fine so I never bothered to solve it.

    https://www.reddit.com/r/GooglePixel/comments/842etl/how_i_fixed_my_5ghz_wifi_issues/

    That's the only solution I could really find for you. The other thing to check is like deathnote said, make sure it's not WPA3 (even though it seems like your phone should support).

    Number One Tricky
  • mRahmanimRahmani DetroitRegistered User regular
    I don't recall what phone my aunt has, but it refused to connect to my parents Wi-Fi when I replaced their router. The solution, bizarrely, was to turn on Bluetooth. The Wi-Fi wouldn't stay connected if Bluetooth was off, but worked perfectly with Bluetooth enabled.

    No idea why.

  • SmrtnikSmrtnik job boli zub Registered User regular
    One of two things fixed it, i did both at the same time. I suspect it was thing 1.

    Thing 1: the router came with an app to use for admin, so you could admin from other than desktop. It seems the app was autochoosing the network to join, but something may have been screwy about it. I uninstalled the app, which let me put in actual wifi credentials.

    Thing 2: once i was on actual wifi i had to set it to use actual hardware MAC instead of randomizing each time it connects (a security feature apparently?) since i whitelist in router by MAC. None of these options were available when the app was filling it in.

    Now everything is great!

    steam_sig.png
    spool32Zilla360Mugsley
Sign In or Register to comment.