As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Blocking Bittorrent seeding (Ares)

GihgehlsGihgehls Registered User regular
edited January 2008 in Help / Advice Forum
My roommate, bless her heart, just doesn't understand the havok that seeding torrents wrecks on our lowly internet connection. Ping times skyrocket into the >1sec range and downloads crawl. I've tried the diplomatic approach of asking her to turn off Ares when she is done with it, or to disable sharing, or to put a speed limit on the upload, but she doesn't really understand the problem so she doesn't think it is a big deal. I don't care about downloading, but saturating the upstream just kills pretty much everything. Its my router on the network, so I'd like to try a solution there.

I can selectively block incomming connections on whichever ports, and can do that on a shedule, but I'm not sure if that will help anything because I'm not familiar enough with bittorrent and how it works with a NAT. I caught a glimpse of the Ares settings, and it has an option "listen for connections on port X." My understanding is that any unrequested incomming traffic on a NAT is going to be blocked anyway, so would blocking incoming on that port do anything? What is the best technological solution for me?

PA-gihgehls-sig.jpg
Gihgehls on

Posts

  • brandotheninjamasterbrandotheninjamaster Registered User regular
    edited January 2008
    I'm not sure but I think that if you block that port the program may automatically try another .

    brandotheninjamaster on
  • GihgehlsGihgehls Registered User regular
    edited January 2008
    Who knows. I wouldn't think it would since you can only specify one port and it would be odd (read: poor programming) for it to just choose another one. I'm more wondering how incomming works on bittorrent and how incomming connections are established.

    Gihgehls on
    PA-gihgehls-sig.jpg
  • DocDoc Registered User, ClubPA regular
    edited January 2008
    Go to your router and enable MAC address filtering when she's leaving it on. Make sure her MAC address isn't on the list.

    Doc on
  • EggyToastEggyToast Jersey CityRegistered User regular
    edited January 2008
    She's your roommate -- talk with her and tell her that her program is killing the internet connection, and then sit with her and have her fix it. See what her max upload speed is currently, and set the new max for 75% of that or less.

    Don't go behind her back to limit her internet connection, show her how to fix the problem.

    EggyToast on
    || Flickr — || PSN: EggyToast
  • MonoxideMonoxide Registered User, ClubPA regular
    edited January 2008
    There's a setting in uTorrent that will automatically stop seeding once you've reached a certain ratio.

    Set the ratio to 0.1%.

    There's no way that I know of to do this in Ares, but she shouldn't be using Ares to begin with.

    edit: You should be able to set the global max upload rate in both Ares and uTorrent though. Make sure that's set to around 75% of your maximum upload (or less) or else it's just going to saturate the entire line.

    Monoxide on
  • MuridenMuriden Registered User regular
    edited January 2008
    Depending on what sort of router you have you might have a packet queueing service on the router, Linksys calls it QQoS. You can set ares' port to the lowest priority which should help some.

    Best way I can see to fix this though is to get her permission to fiddle with the settings on ares and set the upload cap to a low number. I'm sure you can figure out some sort of justification for this.

    Muriden on
    MrGulio.332 - Lover of fine Cheeses. Replays
    301787-1.png
  • SmasherSmasher Starting to get dizzy Registered User regular
    edited January 2008
    She may not understand the technical explanations, but have you tried showing her what happens? In other words, do a speed test or download or something, turn on the seeding, and then do the test/download again. She may not understand exactly what kilobytes per second means, but if you explain it's a measurement of speed and show it dropping significantly between the two tests she should get the idea.

    Smasher on
  • TavTav Irish Minister for DefenceRegistered User regular
    edited January 2008
    Gimping her download speed without telling her will most likely lead to her thinking that there is a problem, and in my experience, it's the people who know the least about computers who are the first to try and fix problems. I'd recommended telling her what you're going to do as opposed to having her potentially messing up the computer.

    Tav on
  • vonPoonBurGervonPoonBurGer Registered User regular
    edited January 2008
    If you have a router that supports QoS, or is supported by open source firmware (e.g. dd-wrt) that includes QoS, that would be the most elegant solution. Basically, it gives you a way to tell the router what your maximum speeds are, all traffic automatically gets throttled down to that maximum, and you can tell it that bittorrent traffic should take a back seat to all over traffic. I have it enabled on my home network so my girlfriend and I can both be torrenting without having to negotiate limits while at the same time allowing us to use the full capacity of our link when only one person is torrenting.

    vonPoonBurGer on
    Xbox Live:vonPoon | PSN: vonPoon | Steam: vonPoonBurGer
  • JaninJanin Registered User regular
    edited January 2008
    You could also just go into Ares' settings and set it to have a global max upload rate of 5KB/s or something.

    Janin on
    [SIGPIC][/SIGPIC]
  • vonPoonBurGervonPoonBurGer Registered User regular
    edited January 2008
    Janin wrote: »
    You could also just go into Ares' settings and set it to have a global max upload rate of 5KB/s or something.
    That works great, until she says "why do my transfer speeds suck?" and changes the setting. And then forgets to change it back. And then you have to go through the whole rigamarole all over again. QoS may be a lot more effort up front, but it's effort you only have to perform once.

    vonPoonBurGer on
    Xbox Live:vonPoon | PSN: vonPoon | Steam: vonPoonBurGer
  • MonoxideMonoxide Registered User, ClubPA regular
    edited January 2008
    Janin wrote: »
    You could also just go into Ares' settings and set it to have a global max upload rate of 5KB/s or something.
    That works great, until she says "why do my transfer speeds suck?" and changes the setting. And then forgets to change it back. And then you have to go through the whole rigamarole all over again. QoS may be a lot more effort up front, but it's effort you only have to perform once.

    She doesn't sound like the kind of person who is going to care about their upload rate on bittorrent transfers.

    Monoxide on
  • shutzshutz Registered User regular
    edited January 2008
    Monoxide wrote: »
    There's a setting in uTorrent that will automatically stop seeding once you've reached a certain ratio.

    Set the ratio to 0.1%.

    There's no way that I know of to do this in Ares, but she shouldn't be using Ares to begin with.

    edit: You should be able to set the global max upload rate in both Ares and uTorrent though. Make sure that's set to around 75% of your maximum upload (or less) or else it's just going to saturate the entire line.

    Setting the max upload is the way to go. You really shouldn't set the "automatically stop seeding" ratio below 50%, simply because BT is about giving back as much as getting from others, which is why it's generally so fast.

    Also, setting the max upload might actually increase her download speeds, especially if you're on a DSL connection: with DSL, when one direction gets saturated, the other direction automatically slows down. So even if it seems counter-intuitive, just explain to her that you need to set this setting, show her what it is, and explain that it will let the rest of you use the Internet, and it will also likely help speed up her downloads.

    Then tell her that the alternative is that you will start blocking certain things, eventually cutting off all her 'net access if she won't comply.

    If she then keeps acting like it's not important, and keeps changing the setting back to uncapped uploads, she's been warned, go ahead and start playing around with ports or MAC filtering.

    shutz on
    Creativity begets criticism.
    Check out my new blog: http://50wordstories.ca
    Also check out my old game design blog: http://stealmygamedesigns.blogspot.com
  • EggyToastEggyToast Jersey CityRegistered User regular
    edited January 2008
    People who think it's not important are usually the ones who are too lazy to seriously investigate what's going on. the OP doesn't give the impression she's doing this out of malice, but simply out of ignorance. She's probably never even looked at the settings in her program, and just notices when "the file is done."

    EggyToast on
    || Flickr — || PSN: EggyToast
  • GihgehlsGihgehls Registered User regular
    edited January 2008
    Mono and Eggy are right on. She's not malicious, but she is also very stubborn. I will try talking to her again I guess, but like I said before, that didn't do any good. I may have done myself a disservice by asking about this in H/A instead of the tech subforum, but I appreciate the replies. I know my router doesn't have any packet scheduling or traffic prioritization. My quesetion was more about if blocking the incoming port will actually do anything.

    Gihgehls on
    PA-gihgehls-sig.jpg
  • EggyToastEggyToast Jersey CityRegistered User regular
    edited January 2008
    Gihgehls wrote: »
    Mono and Eggy are right on. She's not malicious, but she is also very stubborn. I will try talking to her again I guess, but like I said before, that didn't do any good. I may have done myself a disservice by asking about this in H/A instead of the tech subforum, but I appreciate the replies. I know my router doesn't have any packet scheduling or traffic prioritization. My quesetion was more about if blocking the incoming port will actually do anything.

    If you block the port you'll break her downloads, too. Or cause them to go VERY slowly.

    I've had to fandangle a lot of crap with different networks at home to get Bittorrent to work (I'm a comcast user, yay), and I've played with different apps to get crap to work. I'm currently running it, when I've gotta use it, through a virtual network connection proxy. In all the programs I've used, I've never seen an app that doesn't allow some limits on the upload connection.

    You can tell her that you have no problem with her using bittorrent, but that she's killing the network for you and you can't even load webpages when she's using it because of how her program's uploads are set up, and that it's a very easy thing to change and it won't affect her downloads. Everyone wins. And then go to her computer and look over it with her.

    EggyToast on
    || Flickr — || PSN: EggyToast
  • shutzshutz Registered User regular
    edited January 2008
    And if after everything else she's still too stubborn and resets the setting (thinking that she'll get faster downloads and that you were just whining or something), you can always just unplug her network cable from your router, since you said the router is yours. I mean, if she's going to act childish, treat her like a child. But only do this once all other diplomatic avenues have failed.

    shutz on
    Creativity begets criticism.
    Check out my new blog: http://50wordstories.ca
    Also check out my old game design blog: http://stealmygamedesigns.blogspot.com
  • GihgehlsGihgehls Registered User regular
    edited January 2008
    Persistent diplomacy worked, but like you guessed shutz, she might switch the settings back. Even though I work in the IT field, sometimes I get the impression from her that she doesn't believe the things I say. She's sorta like those people who don't trust doctors. Anyway, this can be locked I guess.

    Gihgehls on
    PA-gihgehls-sig.jpg
Sign In or Register to comment.