As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread:

Fortran question: SOLVED

PemulisPemulis Registered User regular
I am trying to open a scratch file in Fortran90, but keep running into a problem I don't understand.

My syntax is:
OPEN(unit=iunit, form=cunform, status=cscratch, &
& recl=record_in, access=acc_type, iostat=istat)


and record_in is the length of the file in bytes.

If I set record_in to, say 63170704 or anything less, it works fine. When it is 99840064 I get an iostat=41 error. Note that I haven't tried things between these values, but I need 99840064 bytes.

The iostat=41 is a conversion error: "Valid logical input not found in external file."

I don't know what this means. The only thing I can think of is that I am exceeding the maximum record length, but I though this was >2e9, so I don't think this is it.

Any help is greatly appreciated!!!

Pemulis on
Sign In or Register to comment.