As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

SATA Hard Drive installation problem.

OtakuD00DOtakuD00D Can I hit the exploding rocks?San DiegoRegistered User regular
Today, I bought me a 500gb Samsung HD502IJ SATA hard drive. My current setup has two IDE hard drives as a master and slave, and I want this as another secondary drive.

Obviously, SATA doesn't follow those rules. Here's my problem:

BIOS and Samsung's HUTIL programs detect the drive just fine. However, it does not appear in Windows at all, not even in Drive Manager. BIOS has SATA in an IDE setup, which I doubt is the problem. I'm not running a RAID array of any kind. My motherboard has two SATA connections. Does connecting it in either one really matter?

First, I tried booting from my Windows XP cd and partitioning and formatting it there. Big mistake - it went ahead and installed windows XP! Now my computer thinks it's running a dual boot, even though I've long since re-partitioned that damn disk.

Apparently the best solution is to just leave the disk unpartitioned and let Disk Manager do the job. Well... Disk Manager does not detect my drive. Anyone got a solution to this? I have the Ultimate Boot CD, but I don't want to accidentally screw my computer up by running random odd programs from it. HUDISK doesn't do jack shit for me. Half the options don't want to work.

EDIT: NEVERMIND. I FIXED IT. It ended up as some big ? in Device Manager. I had to re-install the controller drivers. Okay. In case the computer still thinks it's dual booting, how do I get rid of that? There's no second windows installation to boot from anymore.

makosig.jpg
OtakuD00D on

Posts

  • blakfeldblakfeld Registered User
    edited November 2008
    DBAN the sata drive? that'll end that right quick.

    blakfeld on
  • DasHanselHMDasHanselHM Registered User
    edited November 2008
    You want to go to System Properties (Right-click "My Computer" and select properties) and click the Advanced tab. Next click on Settings on the Startup and Recovery section. Click on Edit on the window that pops up; you will be editing the boot.ini. Make sure you save a backup of the file incase you delete the wrong thing, but look for the line that looks like this: "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin" except yours will have more than one Microsoft Windows XP Professional entry in it, so delete them all except for the first one. This will get rid of the dual boot menu at startup.

    DasHanselHM on
  • OtakuD00DOtakuD00D Can I hit the exploding rocks? San DiegoRegistered User regular
    edited November 2008
    You want to go to System Properties (Right-click "My Computer" and select properties) and click the Advanced tab. Next click on Settings on the Startup and Recovery section. Click on Edit on the window that pops up; you will be editing the boot.ini. Make sure you save a backup of the file incase you delete the wrong thing, but look for the line that looks like this: "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin" except yours will have more than one Microsoft Windows XP Professional entry in it, so delete them all except for the first one. This will get rid of the dual boot menu at startup.
    Thanks, but here's the tricky part: When I boot up, the first option was the one I accidentally installed, while the second option was the original installation. Is it the same here, or is it really still just the first one?

    Here's what I have:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(2)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(2)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn /usepmtimer


    I noticed the rdisk(2). Does that refer to the disk number? In which case, yeah. The SATA disk has been referenced to as "Disk 2" before.

    OtakuD00D on
    makosig.jpg
  • DasHanselHMDasHanselHM Registered User
    edited December 2008
    They are in the same order in the boot.ini as they are on the menu when it starts up. I should have been more clear about that. So, if option two is the one that you select then delete the first one.

    DasHanselHM on
  • OtakuD00DOtakuD00D Can I hit the exploding rocks? San DiegoRegistered User regular
    edited December 2008
    Got ya. Thanks for the help! Should make sense, especially since rdisk(2) probably refers to it being Disk 2, which the SATA most definitely is, since the others are disks 0 and 1.

    OtakuD00D on
    makosig.jpg
Sign In or Register to comment.