Club PA 2.0 has arrived! If you'd like to access some extra PA content and help support the forums, check it out at patreon.com/ClubPA
The image size limit has been raised to 1mb! Anything larger than that should be linked to. This is a HARD limit, please do not abuse it.
Our new Indie Games subforum is now open for business in G&T. Go and check it out, you might land a code for a free game. If you're developing an indie game and want to post about it, follow these directions. If you don't, he'll break your legs! Hahaha! Seriously though.
Our rules have been updated and given their own forum. Go and look at them! They are nice, and there may be new ones that you didn't know about! Hooray for rules! Hooray for The System! Hooray for Conforming!

Playing StarCraft in Windows 7 on a switch

FremFrem Registered User regular
edited September 2009 in Moe's Stupid Technology Tavern
Last night seven Koreans and two Americans crammed into a tiny dorm room, set up a switch, and played some serious StarCraft in a makeshift PC bang. I was one of the Americans. I was also "that guy." You know. That one guy at a LAN party who can never quite get his computer working properly? Yeah. As if being the only Terran player didn't single me out enough already.

So, Windows 7 seems to be having issues connecting to a switch and seeing everyone else on it. It kept acting like it was trying to get an IP address and connect to the internets, even though the switch didn't have internet access. I couldn't see anyone else in the equivalent of the network places window, and I couldn't see any games anyone else made. This was after properly configuring the Windows firewall and eventually completely disabling it. It didn't make a difference whether my wifi was enabled or not.

I finally loaded up Ubuntu (my main OS) and set NetworkManager to "Local-Link Only" in the IPv4 settings. After that, I could see shared folders on other people's machines and play the game in Wine (although Wine doesn't run the game as smoothly as Windows, and for some reason it acts like the shift key is always held down. Not being able to click on the map is a pretty severe handicap.)

So. Does anyone know how to configure Windows 7 to play nicely with network switches?

Frem on

Posts

  • tachyontachyon Registered User regular
    edited August 2009
    Frem wrote: »
    Last night seven Koreans and two Americans crammed into a tiny dorm room, set up a switch, and played some serious StarCraft in a makeshift PC bang. I was one of the Americans. I was also "that guy." You know. That one guy at a LAN party who can never quite get his computer working properly? Yeah. As if being the only Terran player didn't single me out enough already.

    So, Windows 7 seems to be having issues connecting to a switch and seeing everyone else on it. It kept acting like it was trying to get an IP address and connect to the internets, even though the switch didn't have internet access. I couldn't see anyone else in the equivalent of the network places window, and I couldn't see any games anyone else made. This was after properly configuring the Windows firewall and eventually completely disabling it. It didn't make a difference whether my wifi was enabled or not.

    I finally loaded up Ubuntu (my main OS) and set NetworkManager to "Local-Link Only" in the IPv4 settings. After that, I could see shared folders on other people's machines and play the game in Wine (although Wine doesn't run the game as smoothly as Windows, and for some reason it acts like the shift key is always held down. Not being able to click on the map is a pretty severe handicap.)

    So. Does anyone know how to configure Windows 7 to play nicely with network switches?

    I haven't had this issue, so just throwing out ideas so you can shoot them down. In 'network and sharing center' what is your connection type? It should be set to 'home', if set to 'public' then it kills all network discovery/sharing.

    tachyon on
  • wunderbarwunderbar What Have I Done? Registered User regular
    edited August 2009
    tachyon wrote: »
    Frem wrote: »
    Last night seven Koreans and two Americans crammed into a tiny dorm room, set up a switch, and played some serious StarCraft in a makeshift PC bang. I was one of the Americans. I was also "that guy." You know. That one guy at a LAN party who can never quite get his computer working properly? Yeah. As if being the only Terran player didn't single me out enough already.

    So, Windows 7 seems to be having issues connecting to a switch and seeing everyone else on it. It kept acting like it was trying to get an IP address and connect to the internets, even though the switch didn't have internet access. I couldn't see anyone else in the equivalent of the network places window, and I couldn't see any games anyone else made. This was after properly configuring the Windows firewall and eventually completely disabling it. It didn't make a difference whether my wifi was enabled or not.

    I finally loaded up Ubuntu (my main OS) and set NetworkManager to "Local-Link Only" in the IPv4 settings. After that, I could see shared folders on other people's machines and play the game in Wine (although Wine doesn't run the game as smoothly as Windows, and for some reason it acts like the shift key is always held down. Not being able to click on the map is a pretty severe handicap.)

    So. Does anyone know how to configure Windows 7 to play nicely with network switches?

    I haven't had this issue, so just throwing out ideas so you can shoot them down. In 'network and sharing center' what is your connection type? It should be set to 'home', if set to 'public' then it kills all network discovery/sharing.

    First thing, what's the IP you're getting? Does the switch have DHCP or do you have to set a static IP? As long as DHCP is there, it should just be plug and play. So I'm willing to bet it's an IP address conflict somewhere.

    wunderbar on
    XBL: thewunderbar PSN: thewunderbar NNID: thewunderbar Steam: wunderbar87 Twitter: wunderbar
  • FremFrem Registered User regular
    edited August 2009
    wunderbar wrote: »
    First thing, what's the IP you're getting? Does the switch have DHCP or do you have to set a static IP? As long as DHCP is there, it should just be plug and play. So I'm willing to bet it's an IP address conflict somewhere.

    Don't know; I didn't think to write down the IP address. My university requires that everyone use dynamic IPs when connecting to resnet, and most people don't bother to change it for LAN parties. I don't think anyone else did any additional network config; most of them were using XP. IIRC Windows 7 was just calling the network "Unidentified."
    tachyon wrote: »
    I haven't had this issue, so just throwing out ideas so you can shoot them down. In 'network and sharing center' what is your connection type? It should be set to 'home', if set to 'public' then it kills all network discovery/sharing.

    This might very well be the case. It was set to "public" automatically and I couldn't figure out how to set it to home. I did try to set access for public networks as wide open as possible, but I'm not very experienced with Windows Vista+ networking. Google reveals that clicking the "Public network" text brings up a dialog to change it. Maybe that's it?

    Frem on
  • VelmeranVelmeran Registered User regular
    edited September 2009
    you should of set your IP manually, just look at someone elses and then pick a higher number for the last .XXX number. If you had wireless or any other network adapters turned on, turn them off, even if not connected they can cause conflicts with priority in older games like starcraft.

    Velmeran on
    Vechloran.png
Sign In or Register to comment.