As was foretold, we've added advertisements to the forums! If you have questions, or if you encounter any bugs, please visit this thread: https://forums.penny-arcade.com/discussion/240191/forum-advertisement-faq-and-reports-thread/

Can't edit own post

So this is probably somehow due to my own stupidity, but I can't seem to find a way to edit my own post in the Pax East Room Share thread. I was able to do it before but not anymore. I've tried with different browsers and from multiple machines with the same result (and yes, I'm logged in :P). Kind of important to be able to edit given the nature of the tread.

Posts

  • zerzhulzerzhul Registered User, Moderator mod
    If you read the post I made right after the OP of that thread, you will find your solution.

  • SKiller0SKiller0 Registered User regular
    Ah. My mistake. I didn't realize that "account too new" applied to me. I joined April 2012. :) I'll send my requested corrections/updates to you via PM when it's ready (if that's alright).

    Thanks for responding!

  • zerzhulzerzhul Registered User, Moderator mod
    It can mean time, or number of posts.

Sign In or Register to comment.