Options

Hey, uh, what happened to folks' avatars?

DarkPrimusDarkPrimus Registered User regular
I see some people here and there still have their avatars displaying, but all of a sudden the majority of avatars have been replaced with this:
defaulticon.png
Which is named defaulticon.png but I know for a fact some of the folks sporting it right now had avatars like an hour ago.
b7ikq0nqrjpn.png

DarkPrimus on

Posts

  • Options
    HevachHevach Registered User regular
    edited August 2020
    Most seem to show up if you click through to their profile.

    Seems to be progressively and quickly spreading, when I first saw it a few minutes ago it was only a couple people who I initially assumed were new users. But as I went from thread to thread they slowly took over, now I'm hardly seeing any avatars.

    Edit: as an example, when I clicked on this thread, I still saw DarkPrimus's, after posting this it's gone. Mine's still here for now. Seems to be just me, Tube, and anyone with the default silhouette avatar left on my end.

    Hevach on
  • Options
    DarkPrimusDarkPrimus Registered User regular
    If anyone's avatar isn't going to disappear from our own individual perspectives, I would think it would be the avatar we had chosen ourselves as it's likely archived in our cookies harder than any other.

  • Options
    TubeTube Registered User admin
    It’s cleared up for me now

  • Options
    PhyphorPhyphor Building Planet Busters Tasting FruitRegistered User regular
    If you force a cache refresh with ctrl-f5 they show up on chrome for me, but not on firefox

  • Options
    EncEnc A Fool with Compassion Pronouns: He, Him, HisRegistered User regular
    Im having to f5 refresh every page to get them to come back on Chrome. Its not sticking, they drop on each subsequent page and when reloading pages I've previously refreshed.

  • Options
    Brovid HasselsmofBrovid Hasselsmof [Growling historic on the fury road] Registered User regular
    I cleared my cache, which fixed it, but it signed me out and when I logged back in the avatars are all gone again.

    This is a lot more unsettling than I would have expected, I rely on avatars a lot more than usernames

  • Options
    Brovid HasselsmofBrovid Hasselsmof [Growling historic on the fury road] Registered User regular
    Ironically the only avatar displaying for me is DarkPrimus, the guy who made the broken avatar thread.

    What a coincidence

  • Options
    DarkPrimusDarkPrimus Registered User regular
    Ironically the only avatar displaying for me is DarkPrimus, the guy who made the broken avatar thread.

    What a coincidence

    Your avatar is back and it sure looks like its talking shit to me right now. Also a coincidence, I'm sure. :biggrin:

  • Options
    JusticeforPlutoJusticeforPluto Registered User regular
    I'm having the same issue. Usually if you reload the page enough times they all come back.

  • Options
    DouglasDangerDouglasDanger PennsylvaniaRegistered User regular
    I'm having this issue too

  • Options
    bowenbowen How you doin'? Registered User regular
    It's coming and going for me, sometimes it'll be a page full of weird no-face avatars, other times it'll be normal (with some of the same people).

    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • Options
    Sweeney TomSweeney Tom Registered User regular
    There's been pages in various threads where if I have a post on it, my av is the only one that shows up

    Which I'm fine with, it makes me feel important

  • Options
    LD50LD50 Registered User regular
    I can confirm it's still happening to me. In this thread, everyone's avatar is showing up except for Pyphor's

  • Options
    MegaMan001MegaMan001 CRNA Rochester, MNRegistered User regular
    @DarkPrimus if the only one showing up for me.

    I am in the business of saving lives.
  • Options
    IrukaIruka Registered User, Moderator Mod Emeritus
    we're working on it.

  • Options
    QuidQuid Definitely not a banana Registered User regular
    Iruka wrote: »
    we're working on it.

    Should’ve called it a forum event to keep people busy guessing what the conditions are.

  • Options
    I needed anime to post.I needed anime to post. boom Registered User regular
    m8o4zgbsfvu2.png

    liEt3nH.png
  • Options
    MrMonroeMrMonroe passed out on the floor nowRegistered User regular
    I can also get them to come back by doing ctrl-f5, (chrome) but it comes back when I get back to the page after visiting another. In SE++ main page I got them all to come back but after reading one thread and coming back they're blanks again.

  • Options
    AthenorAthenor Battle Hardened Optimist The Skies of HiigaraRegistered User regular
    So many faceless faces!

    6k2jfhfxtdvo.png

    He/Him | "A boat is always safest in the harbor, but that’s not why we build boats." | "If you run, you gain one. If you move forward, you gain two." - Suletta Mercury, G-Witch
  • Options
    Munkus BeaverMunkus Beaver You don't have to attend every argument you are invited to. Philosophy: Stoicism. Politics: Democratic SocialistRegistered User, ClubPA regular
    MrMonroe wrote: »
    I can also get them to come back by doing ctrl-f5, (chrome) but it comes back when I get back to the page after visiting another. In SE++ main page I got them all to come back but after reading one thread and coming back they're blanks again.

    People keep popping into and out of existence for me.

    Humor can be dissected as a frog can, but dies in the process.
  • Options
    DarkPrimusDarkPrimus Registered User regular
    Yeah it's a rolling outage-style issue for me.

  • Options
    AthenorAthenor Battle Hardened Optimist The Skies of HiigaraRegistered User regular
    My wager's on out of sync databases/clusters! :D

    He/Him | "A boat is always safest in the harbor, but that’s not why we build boats." | "If you run, you gain one. If you move forward, you gain two." - Suletta Mercury, G-Witch
  • Options
    BrainleechBrainleech 機知に富んだコメントはここにあります Registered User regular
    It's odd as they are there and they are not on the next page

  • Options
    discriderdiscrider Registered User regular
    edited August 2020
    ...
    Looks like if I navigate off the page and then hit Back the avatars have loaded.

    .. scratch that, that doesn't seem to work anymore.

    discrider on
  • Options
    PhyphorPhyphor Building Planet Busters Tasting FruitRegistered User regular
    edited August 2020
    All the avatars are present and correct in the initial HTML fetch, and all of the images are fetched. But something overwrites the image url

    Disabling JS for penny-arcade.com does fix it, so it's definitely a JS thing

    Comes from here: https://github.com/vanilla/vanilla/blob/46b4cf2410f05d3731fc544a0daf0302ca785b96/js/global.js#L1575

    Phyphor on
  • Options
    RoyceSraphimRoyceSraphim Registered User regular
  • Options
    ProlegomenaProlegomena Frictionless Spinning The VoidRegistered User regular
    really making it difficult to just reflexively agree with posts because of who else agreed with them

  • Options
    miscellaneousinsanitymiscellaneousinsanity grass grows, birds fly, sun shines, and brother, i hurt peopleRegistered User regular
    edited August 2020
    i see my avatar when i scroll down to the comment box at the bottom, but it's gone on actual posts

    also on mobile i've seen all the avatars load in on the thread index for a split second then disappear

    miscellaneousinsanity on
    uc3ufTB.png
  • Options
    KarlKarl Registered User regular
    edited August 2020
    Phyphor wrote: »
    If you force a cache refresh with ctrl-f5 they show up on chrome for me, but not on firefox

    Ironically when I tried this, it fixed it for everyone elses profile pic bar yours.

    EDIT: The fix seems to be hit and miss. Fixes it for some but not others. And every time I use it, it fixes a new set of profile pictures and others are broken.

    Karl on
  • Options
    DelzhandDelzhand Hard to miss. Registered User regular
    BECOME AS GODS

  • Options
    MadicanMadican No face Registered User regular
    bowen wrote: »
    It's coming and going for me, sometimes it'll be a page full of weird no-face avatars, other times it'll be normal (with some of the same people).

    Oi, I resemble that remark

  • Options
    SorceSorce Not ThereRegistered User regular
    I was messing with my home network this morning, so I totally thought I screwed something up.

    Glad to hear it wasn't on my end; it was starting to drive me nuts.

    sig.gif
  • Options
    klemmingklemming Registered User regular
    I'm getting a thing where I see them all normally for a moment, then most (but not all) get overridden with the default one.
    I'm wondering if it's just an order of scripts in a .js file somewhere that's putting the default image last instead of first, or vise versa.
    (I'm used to these things taking days to track down and the problem being a single line in the wrong place. Computers are fun)

    Nobody remembers the singer. The song remains.
  • Options
    Brovid HasselsmofBrovid Hasselsmof [Growling historic on the fury road] Registered User regular
    I'm having pages where majority show up and then pages with very few or none. Not having any appear/disappear once the page is loaded.

  • Options
    PhyphorPhyphor Building Planet Busters Tasting FruitRegistered User regular
    klemming wrote: »
    I'm getting a thing where I see them all normally for a moment, then most (but not all) get overridden with the default one.
    I'm wondering if it's just an order of scripts in a .js file somewhere that's putting the default image last instead of first, or vise versa.
    (I'm used to these things taking days to track down and the problem being a single line in the wrong place. Computers are fun)

    Yes what you're seeing is the normal page load before the script runs. If the startup script is slow you'll see all the avs show up for a few frames

  • Options
    Who-PsydWho-Psyd Registered User regular
    Only behavior I have noticed is that the first post of every page always loads the Avatar correctly, can be default face for everyone else but that first Poster always seems to work.

  • Options
    GrisloGrislo Registered User regular
    Who-Psyd wrote: »
    Only behavior I have noticed is that the first post of every page always loads the Avatar correctly, can be default face for everyone else but that first Poster always seems to work.

    That's what I'm seeing on this page, too - except for people who haven't chosen an avatar, and admin accounts. So Dark Primus, Tube and you show up with something other that "default face", and Ringo's avatar shows up in reactions since he seems to also use the default avatar.

    This post was sponsored by Tom Cruise.
  • Options
    bowenbowen How you doin'? Registered User regular
    edited August 2020
    Phyphor wrote: »
    All the avatars are present and correct in the initial HTML fetch, and all of the images are fetched. But something overwrites the image url

    Disabling JS for penny-arcade.com does fix it, so it's definitely a JS thing

    Comes from here: https://github.com/vanilla/vanilla/blob/46b4cf2410f05d3731fc544a0daf0302ca785b96/js/global.js#L1575

    adblocking global.js seems to solve the issue on my end... seemingly breaking very little when blocked

    bowen on
    not a doctor, not a lawyer, examples I use may not be fully researched so don't take out of context plz, don't @ me
  • Options
    BrainleechBrainleech 機知に富んだコメントはここにあります Registered User regular
    Odd if I am not logged in I can see the avatars but if I log in poof they go

Sign In or Register to comment.